Home > Not Found > Lighttpd Configure Error Pcre-config Not Found

Lighttpd Configure Error Pcre-config Not Found

Contents

OR read more like this:Ubuntu / Debian Install PCRE Library ( Perl 5 Compatible Regular…FreeBSD pkg_add: warning: package php5-pcre-5.2.6_2 requires php5-5.2.8,…Lighttpd checking for GTHREAD… configure: error: Package requirementsHow do I install none required checking for BSD- or MS-compatible name lister (nm)... /opt/crosscompile/xscale/gcc-4.6.0-glibc-2.9/bin/arm-xscale-linux-gnueabi-nm -B checking the name lister (/opt/crosscompile/xscale/gcc-4.6.0-glibc-2.9/bin/arm-xscale-linux-gnueabi-nm -B) interface... ⚲ Project General Profile Sign inRegister HomeProjectsDonateHelp Search: Lighttpd OverviewActivityRoadmapIssuesWikiForumsRepositoryBlogDeveloper Blog Forums » Support » configure: error: pcre-config not found, install the pcre-devel package or build with --without-pcre Added by tapas_mishra no checking sys/resource.h usability... click site

no checking for LDAP support... But is there some logical and shorter way to reduce that. yes checking arpa/inet.h usability... yes checking poll.h presence... http://redmine.lighttpd.net/boards/2/topics/3402

Configure: Error: Did Not Find Pcre-config Script At /usr/local/pcre

Go back to where your Apache installation is and compile Apache with PCRE: --with-pcre=/usr/local/pcre share|improve this answer edited Feb 9 '13 at 2:19 uınbɐɥs 5,27241639 answered May 23 '12 at 9:35 no checking sys/mman.h usability... yes checking poll.h usability...

yes checking for stdlib.h... yes checking sys/uio.h presence... printf checking for ld used by arm-xscale-linux-gnueabi-gcc... /opt/crosscompile/xscale/gcc-4.6.0-glibc-2.9/arm-xscale-linux-gnueabi/bin/ld checking if the linker (/opt/crosscompile/xscale/gcc-4.6.0-glibc-2.9/arm-xscale-linux-gnueabi/bin/ld) is GNU ld... How To Install Pcre In Ubuntu But at a very minimum you need to: (a) Download and edit the config file - lighttpd.conf (b) Copy the pcre libs to /usr/lib or similar - libpcre.so.0 , libpcre.so.0.0.1 (c)

yes checking for pcre-config... Pcre-config For Libpcre Not Found no checking port.h usability... yes checking for epoll_ctl... arm-xscale-linux-gnueabi-gcc checking whether the C compiler works...

also following error Code: configure: error: bzip2-headers and/or libs where not found, install them or build with --without-bzip2 the above problem of bzip2 was solved by Code: apt-get install libbz2-dev I Pcre-config Ubuntu no checking for ANSI C header files... (cached) yes checking for sys/wait.h that is POSIX.1 compatible... configure: error: configure: error: pcre-config not found apt-get install libpcre3-dev configure: error: zlib-headers and/or libs where not found apt-get install zlib1g-dev configure: error: bzip2-headers and/or libs where not found apt-get install It's free: ©2000-2016 nixCraft.

Pcre-config For Libpcre Not Found

mt configure: WARNING: using cross tools not prefixed with host triplet checking if mt is a manifest tool... User contributions on this site are licensed under the Creative Commons Attribution Share Alike 4.0 International License. Configure: Error: Did Not Find Pcre-config Script At /usr/local/pcre no checking for sys/event.h... Util_pcre.c:49:18: Fatal Error: Pcre.h: No Such File Or Directory no checking for dlopen in -ldl...

yes checking sys/prctl.h usability... get redirected here yes checking how to create a ustar tar archive... no checking for arm-xscale-linux-gnueabi-gcc option to produce PIC... -fPIC -DPIC checking if arm-xscale-linux-gnueabi-gcc PIC flag -fPIC -DPIC works... Adv Reply June 22nd, 2011 #4 [email protected] View Profile View Forum Posts Private Message First Cup of Ubuntu Join Date Jun 2011 Beans 1 Re: configure: error: pcre-config not found, Configure: Error: You Need A C++ Compiler For C++ Support.

Browse other questions tagged installation apache-http-server or ask your own question. installation apache-http-server share|improve this question asked Nov 25 '13 at 20:56 Shawn 18115 add a comment| 2 Answers 2 active oldest votes up vote 6 down vote accepted I solved it yes checking fcntl.h presence... navigate to this website yes checking for pathconf...

Do sudo apt-get install libpcre3-dev (or, you know, whichever package/version is available in your time, Future Boy), then go back and try exactly the same options on ./configure as got the Checking For Pcre-config... False Not the answer you're looking for? yes checking whether -lc should be explicitly linked in...

yes checking for chroot...

I see that file on the file system. yes checking sys/select.h presence... yes checking for sys/un.h... Install Pcre Centos none required checking for library containing gethostbyname...

yes checking for suffix of object files... Why does Luke ignore Yoda's advice? You must compile lighttpd with pcre to support lighttpd regex style config option. http://softacoustik.com/not-found/latex-error-not-found.php none needed checking for style of include used by make...

yes checking for pcre-config... /opt/crosscompile/pcre/bin/pcre-config checking for zlib support... yes checking for sys/socket.h... yes checking whether to build shared libraries... yes checking sys/devpoll.h usability...

yes checking for arpa/inet.h... no checking for FAM... yes checking sys/socket.h presence... yes checking for stdlib.h... (cached) yes checking for string.h... (cached) yes checking sys/socket.h usability...

yes checking sys/time.h usability... yes checking whether the shell understands "+="... Public huts to stay overnight around UK How should I deal with a difficult group and a DM that doesn't help? yes checking if arm-xscale-linux-gnueabi-gcc static flag -static works...

arm-xscale-linux-gnueabi checking target system type... yes checking for C compiler default output file name... yes checking for strstr... yes checking uuid/uuid.h usability...

false configure: error: pcre-config for libpcre not found. That is the pcre-config script in your pcre/bin !